summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-06-16 15:29:13 +0200
committersL1pKn072018-06-16 15:29:13 +0200
commit3b6dd52889db4b1552a59083066e6ad7c6b14350 (patch)
treefcfe177b270b2fe557b7fd8599d0c6ecc4e1c093
parent4d5519cbf59902e3f1f4909232ddf046f8622668 (diff)
downloadaur-3b6dd52889db4b1552a59083066e6ad7c6b14350.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD25
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7326da4cbb94..32a3e6cfc3d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Oct 19 21:31:06 UTC 2016
+# Sat Jun 16 13:29:08 UTC 2018
pkgbase = vapoursynth-plugin-awarpsharp2-git
pkgdesc = Plugin for Vapoursynth: awarpsharp2 (GIT version)
- pkgver = v3.0.g769e2be
+ pkgver = v4.0.g886d4b7
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=172721
arch = i686
arch = x86_64
license = GPL2
makedepends = git
+ makedepends = meson
depends = vapoursynth
provides = vapoursynth-plugin-awarpsharp2
conflicts = vapoursynth-plugin-awarpsharp2
diff --git a/PKGBUILD b/PKGBUILD
index 1b7cd1986e45..6751ebfc9c0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
_plug=awarpsharp2
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v3.0.g769e2be
+pkgver=v4.0.g886d4b7
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
url='http://forum.doom9.org/showthread.php?t=172721'
license=('GPL2')
depends=('vapoursynth')
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
@@ -21,20 +23,19 @@ pkgver() {
}
prepare() {
- cd "${_plug}"
- ./autogen.sh
+ mkdir -p build
+
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
}
build() {
- cd "${_plug}"
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib/vapoursynth
- make
+ ninja -C build
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}