summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-15 03:18:31 +0200
committersL1pKn072019-04-15 03:18:31 +0200
commitb62d8428f68fb835809bb313da32b2e2ffb2632b (patch)
treecf57b3eff95d8a971d3c073a27487ebc9e12b170
downloadaur-b62d8428f68fb835809bb313da32b2e2ffb2632b.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..049a0615c409
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Apr 15 01:18:31 UTC 2019
+pkgbase = vapoursynth-plugin-bilateralgpu-git
+ pkgdesc = Plugin for Vapoursynth: bilateralgpu (GIT version)
+ pkgver = r4.4.gc861ec6
+ pkgrel = 1
+ url = https://github.com/WolframRhodium/VapourSynth-BilateralGPU
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ depends = opencv-cuda
+ provides = vapoursynth-plugin-bilateralgpu
+ conflicts = vapoursynth-plugin-bilateralgpu
+ source = bilateralgpu::git+https://github.com/WolframRhodium/VapourSynth-BilateralGPU.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-bilateralgpu-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e1e93561c0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=bilateralgpu
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r4.4.gc861ec6
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/WolframRhodium/VapourSynth-BilateralGPU'
+license=('GPL')
+depends=('vapoursynth'
+ 'opencv-cuda'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/WolframRhodium/VapourSynth-BilateralGPU.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+prepare() {
+ cd "${_plug}"
+
+ sed 's|<vapoursynth/|<|g' -i bilateralGPU/bilateral.cpp
+
+ echo "all:
+ g++ -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) $(pkg-config --cflags opencv4) -o bilateral.o bilateralGPU/bilateral.cpp
+ g++ -shared -lopencv_core -lopencv_cudaarithm -lopencv_cudafilters -lopencv_cudaimgproc -lopencv_cudev -lopencv_imgproc -fPIC ${LDFLAGS} -o lib${_plug}.so bilateral.o" > Makefile
+}
+
+build() {
+ make -C "${_plug}"
+}
+
+package() {
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}