summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-06 21:03:40 +0100
committersL1pKn072022-02-06 21:03:40 +0100
commitb958cf15995ace42d57fa5b334d1926540c13ff1 (patch)
tree7db64451f41a35a53be64cd263b65a343a2372ea
parent67904474d91b6b6e31538a3bd9994f52d5e53ec4 (diff)
downloadaur-b958cf15995ace42d57fa5b334d1926540c13ff1.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b5ec61c5b92..f4b94889adba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = vapoursynth-plugin-bilateralgpu-git
pkgdesc = Plugin for Vapoursynth: bilateralgpu (GIT version)
- pkgver = r6.3.g69af543
+ pkgver = r8.0.g1661823
pkgrel = 1
url = https://github.com/WolframRhodium/VapourSynth-BilateralGPU
arch = x86_64
- license = GPL
+ license = MIT
makedepends = git
makedepends = cmake
+ makedepends = cuda
depends = vapoursynth
- depends = cuda
+ depends = nvidia-utils
provides = vapoursynth-plugin-bilateralgpu
conflicts = vapoursynth-plugin-bilateralgpu
source = bilateralgpu::git+https://github.com/WolframRhodium/VapourSynth-BilateralGPU.git
diff --git a/PKGBUILD b/PKGBUILD
index f8f310df36de..e4563637d539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
_plug=bilateralgpu
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r6.3.g69af543
+pkgver=r8.0.g1661823
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/WolframRhodium/VapourSynth-BilateralGPU'
-license=('GPL')
+license=('MIT')
depends=('vapoursynth'
- 'cuda'
+ 'nvidia-utils'
)
makedepends=('git'
'cmake'
+ 'cuda'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -23,27 +24,25 @@ pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- cd "${_plug}"
- mkdir -p build
-}
build() {
- cd "${_plug}/build"
- cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
+ source /etc/profile.d/cuda.sh
+
+ cmake -S "${_plug}" -B build \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib/vapoursynth \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DVAPOURSYNTH_INCLUDE_DIRECTORY="$(pkg-config --cflags vapoursynth | sed 's|-I||g')" \
-DCMAKE_CUDA_FLAGS="--threads 0 --use_fast_math -Wno-deprecated-gpu-targets" \
- -DVAPOURSYNTH_INCLUDE_DIRECTORY=/usr/include/vapoursynth \
- -DCMAKE_SKIP_RPATH=ON
+ -DUSE_NVRTC_STATIC=ON
- make
+ cmake --build build
}
package() {
- cd "${_plug}"
- install -Dm755 "build/source/lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm755 "build/rtc_source/lib${_plug}_rtc.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}_rtc.so"
+ DESTDIR="${pkgdir}" cmake --install build
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}