summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWoofinaS2022-08-17 22:59:24 -0400
committerWoofinaS2022-08-17 22:59:24 -0400
commit87cc7bf245167d8086f5101b11089d0fcbb76cf0 (patch)
treeac76975b9b55fee566b389cdaa50eeaf0e2907ba
downloadaur-87cc7bf245167d8086f5101b11089d0fcbb76cf0.tar.gz
inital commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd54637b0230
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vapoursynth-plugin-bm3dcuda-cpu-git
+ pkgdesc = Plugin for Vapoursynth: bm3dcuda-cpu (GIT version)
+ pkgver = 2.10.1.g6ce6828
+ pkgrel = 1
+ url = https://github.com/WolframRhodium/VapourSynth-BM3DCUDA
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = vapoursynth
+ provides = vapoursynth-plugin-bm3dcuda-cpu
+ conflicts = vapoursynth-plugin-bm3dcuda
+ conflicts = vapoursynth-plugin-bm3dcuda-git
+ options = !strip
+ options = debug
+ source = bm3dcuda::git+https://github.com/WolframRhodium/VapourSynth-BM3DCUDA.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-bm3dcuda-cpu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5fd1cdaade7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: WoofinaS <woofina.s.love@gmail.com>
+
+pkgname=vapoursynth-plugin-bm3dcuda-cpu-git
+pkgver=2.10.1.g6ce6828
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: bm3dcuda-cpu (GIT version)"
+arch=('x86_64')
+url='https://github.com/WolframRhodium/VapourSynth-BM3DCUDA'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git' 'cmake')
+provides=('vapoursynth-plugin-bm3dcuda-cpu')
+conflicts=('vapoursynth-plugin-bm3dcuda' 'vapoursynth-plugin-bm3dcuda-git')
+source=('bm3dcuda::git+https://github.com/WolframRhodium/VapourSynth-BM3DCUDA.git')
+sha256sums=('SKIP')
+options=('!strip' 'debug')
+
+pkgver() {
+ cd "bm3dcuda"
+ echo "$(git describe --long --tags | tr - . | tr -d R)"
+}
+
+build() {
+ cd "bm3dcuda"
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib/vapoursynth \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DVAPOURSYNTH_INCLUDE_DIRECTORY="$(pkg-config --cflags vapoursynth | sed 's|-I||g')" \
+ -DENABLE_CUDA=0
+ make -C build
+}
+
+package() {
+ cd "bm3dcuda"
+ make -C build DESTDIR="$pkgdir" install
+ install -Dm644 "./README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/bm3dcuda/README.md"
+}