summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-08-31 15:01:20 +0200
committersL1pKn072023-08-31 15:01:20 +0200
commit87e82c79d07bf5bca2428b260b07bf554524c96b (patch)
tree27265db854f4dd1f82fe7f1e6cc0cd098f2f1f9c
parentd73f1320c428ee31b82facd69a3a4384a973b935 (diff)
downloadaur-87e82c79d07bf5bca2428b260b07bf554524c96b.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 019ef268bfbb..a2ed8c4c182a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-bm3dcuda-git
pkgdesc = Plugin for Vapoursynth: bm3dcuda (GIT version)
- pkgver = 2.6.1.gf9504cd
+ pkgver = 2.13.0.gd073d98
pkgrel = 1
url = https://github.com/WolframRhodium/VapourSynth-BM3DCUDA
arch = x86_64
@@ -8,8 +8,9 @@ pkgbase = vapoursynth-plugin-bm3dcuda-git
makedepends = git
makedepends = cmake
makedepends = cuda
+ makedepends = nvidia-utils
depends = vapoursynth
- depends = nvidia-utils
+ optdepends = nvidia-utils: CUDA support
provides = vapoursynth-plugin-bm3dcuda
conflicts = vapoursynth-plugin-bm3dcuda
options = debug
diff --git a/PKGBUILD b/PKGBUILD
index 70e07171f305..f627c58eaea8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=bm3dcuda
-pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=2.6.1.gf9504cd
+pkgname="vapoursynth-plugin-${_plug}-git"
+pkgver=2.13.0.gd073d98
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/WolframRhodium/VapourSynth-BM3DCUDA'
license=('GPL')
-depends=('vapoursynth'
- 'nvidia-utils'
- )
-makedepends=('git'
- 'cmake'
- 'cuda'
- )
+depends=('vapoursynth')
+makedepends=(
+ 'git'
+ 'cmake'
+ 'cuda'
+ 'nvidia-utils'
+)
+optdepends=('nvidia-utils: CUDA support')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/WolframRhodium/VapourSynth-BM3DCUDA.git")
@@ -23,7 +24,7 @@ options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - . | tr -d R)"
+ echo "$(git describe --long --tags | tr - . | tr -d R | sed 's|test.||g')"
}
build() {