summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-10 05:22:34 +0200
committersL1pKn072021-10-10 05:22:34 +0200
commitaf567bb10c9d746f83b3d095aac70787a4c36a90 (patch)
treea8c1cbe42ec5b354fafd4454cdf2f254294c079b
downloadaur-af567bb10c9d746f83b3d095aac70787a4c36a90.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdaf822c690b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-bm3dcuda-git
+ pkgdesc = Plugin for Vapoursynth: bm3dcuda (GIT version)
+ pkgver = R2.4.15.g9f7b3c1
+ pkgrel = 1
+ url = https://github.com/WolframRhodium/VapourSynth-BM3DCUDA
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = vapoursynth
+ depends = fftw
+ provides = vapoursynth-plugin-bm3dcuda
+ conflicts = vapoursynth-plugin-bm3dcuda
+ source = bm3dcuda::git+https://github.com/WolframRhodium/VapourSynth-BM3DCUDA.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-bm3dcuda-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a52f61a1deea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=bm3dcuda
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=R2.4.15.g9f7b3c1
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/WolframRhodium/VapourSynth-BM3DCUDA'
+license=('GPL')
+depends=('vapoursynth'
+ 'fftw'
+ )
+makedepends=('git'
+ 'cmake'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/WolframRhodium/VapourSynth-BM3DCUDA.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ CXXFLAGS+=" $(pkg-config --cflags vapoursynth)" cmake ../bm3dcuda \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package(){
+ install -Dm755 build/cpu_source/libbm3dcpu.so "${pkgdir}/usr/lib/vapoursynth/libbm3dcpu.so"
+ install -Dm755 build/source/libbm3dcuda.so "${pkgdir}/usr/lib/vapoursynth/libbm3dcuda.so"
+ install -Dm755 build/rtc_source/libbm3dcuda_rtc.so "${pkgdir}/usr/lib/vapoursynth/libbm3dcuda_rtc.so"
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}