summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Holmer2023-04-03 09:02:16 -0400
committerJoshua Holmer2023-04-03 09:02:16 -0400
commit5604b7dc2faada0ff54308d9e8d542392000b74a (patch)
tree4af402ffc8b555f561542d649e6a77e98824b67d
downloadaur-5604b7dc2faada0ff54308d9e8d542392000b74a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d665ce737ac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vapoursynth-plugin-chickendream-git
+ pkgdesc = Plugin for Vapoursynth: chickendream (GIT version)
+ pkgver = r2.1.ga59183f
+ pkgrel = 1
+ url = https://github.com/EleonoreMizo/chickendream
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = autogen
+ depends = vapoursynth
+ provides = vapoursynth-plugin-chickendream
+ conflicts = vapoursynth-plugin-chickendream
+ source = chickendream::git+https://github.com/EleonoreMizo/chickendream.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-chickendream-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97786c7e71c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Joshua Holmer <jholmer.in@gmail.com>
+
+_plug=chickendream
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2.1.ga59183f
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/EleonoreMizo/chickendream'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git'
+ 'autogen'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/EleonoreMizo/chickendream.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_plug}/build/unix"
+ chmod +x autogen.sh
+ ./autogen.sh
+ ./configure
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/lib/vapoursynth/"
+ cp "${_plug}/build/unix/.libs/libchickendream.so" "${pkgdir}/usr/lib/vapoursynth/"
+}