summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-09-03 20:58:21 +0200
committerGustavo Alvarez2016-09-03 20:58:21 +0200
commitabc26ed4fa43e85523639c599ccca22f618f41f2 (patch)
tree4fb0f64f63699a08f67f8b2713fe50dbab0640fe
downloadaur-abc26ed4fa43e85523639c599ccca22f618f41f2.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b10b5f5f96b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Sep 3 18:58:21 UTC 2016
+pkgbase = vapoursynth-plugin-cmedian-hg
+ pkgdesc = Plugin for Vapoursynth: cmedian (HG version)
+ pkgver = 9.46063df02b42
+ pkgrel = 1
+ url = https://bitbucket.org/James1201/vapoursynth-cmedian
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = mercurial
+ depends = vapoursynth
+ provides = vapoursynth-plugin-cmedian
+ conflicts = vapoursynth-plugin-cmedian
+ source = cmedian::hg+https://bitbucket.org/James1201/vapoursynth-cmedian
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-cmedian-hg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d23d97518ac3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=cmedian
+pkgname=vapoursynth-plugin-${_plug}-hg
+pkgver=9.46063df02b42
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (HG version)"
+arch=('i686' 'x86_64')
+url='https://bitbucket.org/James1201/vapoursynth-cmedian'
+license=('LGPL2.1')
+depends=('vapoursynth')
+makedepends=('mercurial')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::hg+https://bitbucket.org/James1201/vapoursynth-cmedian")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(hg log -r -1 --template '{rev}.{node|short}\n')"
+}
+
+prepare() {
+ cd "${_plug}"
+ chmod +x autogen.sh
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --libdir="/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}