summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-07-03 01:34:10 +0200
committerGustavo Alvarez2016-07-03 01:34:10 +0200
commita662c60a9d947a07835a616e24a499d3fec2ee7d (patch)
tree577ed94a07e76ec8714afe0b3e12e69b043d36f7
downloadaur-a662c60a9d947a07835a616e24a499d3fec2ee7d.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..371177b4fe70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jul 2 23:34:10 UTC 2016
+pkgbase = vapoursynth-plugin-cnr2-git
+ pkgdesc = Plugin for Vapoursynth: cnr2 (GIT version)
+ pkgver = v1.0.gefbc438
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=173659
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-cnr2
+ conflicts = vapoursynth-plugin-cnr2
+ options = !makeflags
+ source = cnr2::git+https://github.com/dubhater/vapoursynth-cnr2.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-cnr2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4479b09db251
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=cnr2
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.gefbc438
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=173659"
+license=('GPL')
+depends=('vapoursynth'
+ )
+makedepends=('git'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha1sums=('SKIP')
+options=('!makeflags')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}