summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-09 20:11:07 +0100
committersL1pKn072019-02-09 20:11:07 +0100
commit6cdcce7aca1ab6df0420f0b2eaf0b26ea159dd46 (patch)
tree414ea0a12c1777b65db1445e8009a56e5d7c3943
downloadaur-6cdcce7aca1ab6df0420f0b2eaf0b26ea159dd46.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fc3c57f0ad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Feb 9 19:11:07 UTC 2019
+pkgbase = vapoursynth-plugin-colorfade-git
+ pkgdesc = Plugin for Vapoursynth: colorfade (GIT Version)
+ pkgver = r9.bed42cc
+ pkgrel = 1
+ url = https://github.com/tormaid/colorfade
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-colorfade
+ conflicts = vapoursynth-plugin-colorfade
+ source = colorfade::git+https://github.com/tormaid/colorfade.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-colorfade-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aee0fe141406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=colorfade
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r9.bed42cc
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
+arch=('any')
+url='https://github.com/tormaid/colorfade'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/tormaid/colorfade.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+} \ No newline at end of file