summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-09 19:57:37 +0100
committersL1pKn072019-02-09 19:57:37 +0100
commit58a172206dde5fe806d165b9557a95096a903e55 (patch)
tree5d0ab68bbae0b45335df8cd6feb1174baa524bdd
parentdae776bc8414b1622e9792af0abb838e89e12a31 (diff)
downloadaur-58a172206dde5fe806d165b9557a95096a903e55.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5431d9b37f4c..ddb9b31facf1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 20:28:04 UTC 2015
+# Sat Feb 9 18:57:33 UTC 2019
pkgbase = vapoursynth-plugin-combmask-git
pkgdesc = Plugin for Vapoursynth: combmask (GIT version)
- pkgver = r18.2ec6679
+ pkgver = 1.1.0.1.g9c708d7
pkgrel = 1
url = https://github.com/chikuzen/combmask
- arch = i686
arch = x86_64
license = LGPL2.1
makedepends = git
@@ -13,7 +12,7 @@ pkgbase = vapoursynth-plugin-combmask-git
provides = vapoursynth-plugin-combmask
conflicts = vapoursynth-plugin-combmask
source = git+https://github.com/chikuzen/combmask.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-combmask-git
diff --git a/PKGBUILD b/PKGBUILD
index e5b3ef1b2b18..875281a78e53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
_plug=combmask
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r18.2ec6679
+pkgver=1.1.0.1.g9c708d7
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/chikuzen/${_plug}"
license=('LGPL2.1')
depends=('vapoursynth')
@@ -13,31 +13,34 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("git+https://github.com/chikuzen/${_plug}.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
- #echo "$(git describe --long --tags | tr - .)"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "$(git describe --long --tags | tr - .)"
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "${_plug}/vapoursynth/src"
- rm VapourSynth.h
-
+ rm -fr VapourSynth.h
+
chmod +x configure
}
build() {
cd "${_plug}/vapoursynth/src"
- ./configure --extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
- --extra-ldflags="${LDFLAGS}"
+ ./configure \
+ --extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
+ --extra-ldflags="${LDFLAGS}"
+
make
}
package(){
cd "${_plug}/vapoursynth/src"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
install -Dm644 ../readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
}