summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-10-11 13:20:47 +0200
committersl1pkn072015-10-11 13:20:47 +0200
commite5b4edb3361ec079876141f1ef1949366b13d7f1 (patch)
tree49f65df5ce7a78304897c17f389eef5a4d6c0ffc
downloadaur-e5b4edb3361ec079876141f1ef1949366b13d7f1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9e7ad3016c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-combmask-git
+ pkgdesc = Plugin for Vapoursynth: combmask (GIT version)
+ pkgver = r18.2ec6679
+ pkgrel = 1
+ url = https://github.com/chikuzen/combmask
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-combmask
+ conflicts = vapoursynth-plugin-combmask
+ source = git+https://github.com/chikuzen/combmask.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-combmask-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0c283253d0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=combmask
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r18.2ec6679
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="https://github.com/chikuzen/${_plug}"
+license=('LGPL2.1')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("git+https://github.com/chikuzen/${_plug}.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_plug}/vapoursynth/src"
+ rm VapourSynth.h
+
+ chmod +x configure
+}
+
+build() {
+ cd "${_plug}/vapoursynth/src"
+ ./configure --extra-cflags="${CFLAGS} $(pkg-config --cflags vapoursynth)" \
+ --extra-ldflags="${LDFLAGS}"
+ make
+}
+
+package(){
+ cd "${_plug}/vapoursynth/src"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm644 ../readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+}
+