summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-09-21 15:32:37 +0200
committersl1pkn072015-09-21 15:32:37 +0200
commit791d88f3fb24b1f99d8d1c4e76f69a14d9ff6e9b (patch)
treef14dbfe4b23dc4587b0be731d0fe3693f89d8512
parentd1143732a2b11a69075a74967d7d353bd6b28846 (diff)
downloadaur-791d88f3fb24b1f99d8d1c4e76f69a14d9ff6e9b.tar.gz
Add -std=gnu++11
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67a1a2f3dafc..4623ebdc5b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=v6.0.gf1bc9a9
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
-url="http://forum.doom9.org/showthread.php?t=171785"
+url='http://forum.doom9.org/showthread.php?t=171785'
license=('GPL')
depends=('vapoursynth')
makedepends=('git')
@@ -23,7 +23,7 @@ pkgver() {
prepare() {
cd "${_plug}"
echo "all:
- g++ -shared ${CFLAGS} -msse2 -mfpmath=sse -Wall -fPIC -o lib${_plug}.so continuity.cpp -I. $(pkg-config --cflags vapoursynth)" > Makefile
+ g++ -o lib${_plug}.so -std=gnu++11 ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} $(pkg-config --cflags vapoursynth) continuity.cpp -shared -msse2 -mfpmath=sse -Wall -fPIC" > Makefile
}
build() {
@@ -34,5 +34,5 @@ build() {
package(){
cd "${_plug}"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}