summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:32:39 +0200
committersl1pkn072015-06-08 20:32:39 +0200
commit7d24eafac903e5a749cfc76cce24cc86ed755236 (patch)
tree8a896cf83ec180bbb0c90bb3d84fd1a5bcce2c8f
downloadaur-7d24eafac903e5a749cfc76cce24cc86ed755236.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e89dc6f10b25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-continuityfixer-git
+ pkgdesc = Plugin for Vapoursynth: continuityfixer
+ pkgver = v6.0.gf1bc9a9
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171785
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-continuityfixer
+ conflicts = vapoursynth-plugin-continuityfixer
+ source = continuityfixer::git+https://github.com/MonoS/VS-ContinuityFixer.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-continuityfixer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d2e4b0b446f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=continuityfixer
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v6.0.gf1bc9a9
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171785"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/MonoS/VS-ContinuityFixer.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - . | tr V v)"
+}
+
+prepare() {
+ cd "${_plug}"
+ echo "all:
+ g++ -shared ${CFLAGS} -msse2 -mfpmath=sse -Wall -fPIC -o lib${_plug}.so continuity.cpp -I. $(pkg-config --cflags vapoursynth)" > Makefile
+}
+
+build() {
+ cd "${_plug}"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+}