summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-09 20:03:00 +0100
committersL1pKn072019-02-09 20:03:00 +0100
commitf8d75ff44acf5733f0afd7edb0e8af64108f42e7 (patch)
tree0c0989e637b5b36778a345f50256ffa36ade09ba
parent791d88f3fb24b1f99d8d1c4e76f69a14d9ff6e9b (diff)
downloadaur-f8d75ff44acf5733f0afd7edb0e8af64108f42e7.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6869b4955d1d..e2636c730677 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Sat Feb 9 19:02:55 UTC 2019
pkgbase = vapoursynth-plugin-continuityfixer-git
pkgdesc = Plugin for Vapoursynth: continuityfixer (GIT version)
pkgver = v6.0.gf1bc9a9
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171785
- arch = i686
arch = x86_64
license = GPL
makedepends = git
@@ -11,7 +12,7 @@ pkgbase = vapoursynth-plugin-continuityfixer-git
provides = vapoursynth-plugin-continuityfixer
conflicts = vapoursynth-plugin-continuityfixer
source = continuityfixer::git+https://github.com/MonoS/VS-ContinuityFixer.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-continuityfixer-git
diff --git a/PKGBUILD b/PKGBUILD
index 4623ebdc5b07..d84b5ff892f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=v6.0.gf1bc9a9
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://forum.doom9.org/showthread.php?t=171785'
license=('GPL')
depends=('vapoursynth')
@@ -13,7 +13,7 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/MonoS/VS-ContinuityFixer.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -23,7 +23,8 @@ pkgver() {
prepare() {
cd "${_plug}"
echo "all:
- g++ -o lib${_plug}.so -std=gnu++11 ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} $(pkg-config --cflags vapoursynth) continuity.cpp -shared -msse2 -mfpmath=sse -Wall -fPIC" > Makefile
+ g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o continuity.o continuity.cpp
+ g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so continuity.o" > Makefile
}
build() {
@@ -34,5 +35,6 @@ build() {
package(){
cd "${_plug}"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}