summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:32:44 +0200
committersl1pkn072015-06-08 20:32:44 +0200
commit8329e14690bde456ccab9d2434c48e2287d32491 (patch)
tree37f96eaceddd327a6e6b811ea141a5c692bcadd2
downloadaur-8329e14690bde456ccab9d2434c48e2287d32491.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bd2fa9e7f47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-convo2d-git
+ pkgdesc = Plugin for Vapoursynth: convo2d (GIT version)
+ pkgver = 20121214.39fdd09
+ pkgrel = 1
+ url = https://github.com/chikuzen/convo2d
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-convo2d
+ conflicts = vapoursynth-plugin-convo2d
+ source = git+https://github.com/chikuzen/convo2d.git
+ md5sums = SKIP
+
+pkgname = vapoursynth-plugin-convo2d-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..611433a76889
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=convo2d
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=20121214.39fdd09
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="https://github.com/chikuzen/${_plug}"
+license=('LGPL2.1')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("git+https://github.com/chikuzen/${_plug}.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ cd "${_gitname}"
+ rm VapourSynth.h
+}
+
+build() {
+ cd "${_gitname}"
+ ./configure --extra-cflags="$(pkg-config --cflags vapoursynth)"
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+}
+