summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-09 20:05:16 +0100
committersL1pKn072019-02-09 20:05:16 +0100
commitacdc9c9b3401a243b481a1e1f55cae4d415d3295 (patch)
treec3dc4273977a09eaa40358e2a26a62ebf733517d
parent01bf4649f84339d4f18d895e4bdcd8d1a4bf38d0 (diff)
downloadaur-acdc9c9b3401a243b481a1e1f55cae4d415d3295.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c287e589826f..e100839f4ce2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 20:31:35 UTC 2015
+# Sat Feb 9 19:05:12 UTC 2019
pkgbase = vapoursynth-plugin-convo2d-git
pkgdesc = Plugin for Vapoursynth: convo2d (GIT version)
pkgver = r15.39fdd09
pkgrel = 1
url = https://github.com/chikuzen/convo2d
- arch = i686
arch = x86_64
license = LGPL2.1
makedepends = git
@@ -13,7 +12,7 @@ pkgbase = vapoursynth-plugin-convo2d-git
provides = vapoursynth-plugin-convo2d
conflicts = vapoursynth-plugin-convo2d
source = git+https://github.com/chikuzen/convo2d.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-convo2d-git
diff --git a/PKGBUILD b/PKGBUILD
index e1d822057340..58ec5991807a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=r15.39fdd09
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/chikuzen/${_plug}"
license=('LGPL2.1')
depends=('vapoursynth')
@@ -13,7 +13,7 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("git+https://github.com/chikuzen/${_plug}.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -23,19 +23,22 @@ pkgver() {
prepare() {
cd "${_plug}"
- rm VapourSynth.h
+ rm -fr VapourSynth.h
}
build() {
cd "${_plug}"
- ./configure --extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
- --extra-ldflags="${LDFLAGS}"
+ ./configure \
+ --extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
+ --extra-ldflags="${LDFLAGS}"
+
make
}
package(){
cd "${_plug}"
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
}