summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-09 20:19:55 +0100
committersL1pKn072019-02-09 20:19:55 +0100
commit24fc954a6f71f7ffa271602ecac60eb1ddee6b11 (patch)
tree579648c12755acd88e1cac59d007dcb3cabc7143
parent89175eba757b7ea7d883e6c85f9335de9f9cc67b (diff)
downloadaur-24fc954a6f71f7ffa271602ecac60eb1ddee6b11.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc88eda744e1..9a12bde725c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Tue May 29 15:06:32 UTC 2018
+# Sat Feb 9 19:19:48 UTC 2019
pkgbase = vapoursynth-plugin-d2vsource-git
pkgdesc = Plugin for Vapoursynth: d2vsource (GIT version)
pkgver = v1.1.7.g99b10e3
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=166399
- arch = i686
arch = x86_64
license = LGPL2.1
makedepends = git
@@ -15,7 +14,7 @@ pkgbase = vapoursynth-plugin-d2vsource-git
depends = libavcodec.so
provides = vapoursynth-plugin-d2vsource
conflicts = vapoursynth-plugin-d2vsource
- source = git+https://github.com/dwbuiten/d2vsource.git
+ source = d2vsource::git+https://github.com/dwbuiten/d2vsource.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-d2vsource-git
diff --git a/PKGBUILD b/PKGBUILD
index dbe49a5be8a0..3a23fcfac98a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=v1.1.7.g99b10e3
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
-url="https://forum.doom9.org/showthread.php?t=166399"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=166399'
license=('LGPL2.1')
depends=('vapoursynth'
'libavutil.so'
@@ -16,7 +16,7 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("git+https://github.com/dwbuiten/${_plug}.git")
+source=("${_plug}::git+https://github.com/dwbuiten/${_plug}.git")
sha256sums=('SKIP')
pkgver() {
@@ -29,20 +29,20 @@ prepare() {
cd "${_plug}"
./autogen.sh
+}
- cd ../build
+build() {
+ cd build
../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth
-}
-
-build() {
- make -C build
+ make
}
package(){
make -C build DESTDIR="${pkgdir}" install
+
install -Dm644 "${_plug}/README" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}