summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-29 14:59:17 +0200
committersl1pkn072015-06-29 14:59:17 +0200
commit45d17f159e5fdee3d2d6d13b7e3302efa55fb917 (patch)
tree46f103d4ca51f3138c772ce72b4bc42218fdfee8
parent737958da0ef812e2284ccc0c750f3234e6d40567 (diff)
downloadaur-45d17f159e5fdee3d2d6d13b7e3302efa55fb917.tar.gz
Fix missing... all(?)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffea8ff9845f..d8a5695cc557 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-d2vsource-git
pkgdesc = Plugin for Vapoursynth: d2vsource (GIT version)
- pkgver = beta7.4.g2859cb6
+ pkgver = beta7.8.gc160a97
pkgrel = 1
url = https://github.com/dwbuiten/d2vsource
arch = i686
@@ -11,7 +11,7 @@ pkgbase = vapoursynth-plugin-d2vsource-git
provides = vapoursynth-plugin-d2vsource
conflicts = vapoursynth-plugin-d2vsource
source = git+https://github.com/dwbuiten/d2vsource.git
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = vapoursynth-plugin-d2vsource-git
diff --git a/PKGBUILD b/PKGBUILD
index 4b6943445152..44c47d8e9792 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=d2vsource
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=beta7.4.g2859cb6
+pkgver=beta7.8.gc160a97
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -13,22 +13,23 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("git+https://github.com/dwbuiten/${_plug}.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
build() {
- cd "${_gitname}"
- ./configure --install="${pkgdir}/usr/lib/vapoursynth"
+ cd "${_plug}"
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth" \
+ --extra-cxxflags="${CXXFLAGS} $(pkg-config --cflags vapoursynth)" \
+ --extra-ldflags="${LDFLAGS}"
make
}
package(){
- cd "${_gitname}"
+ cd "${_plug}"
make install
install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}