summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:32:55 +0200
committersl1pkn072015-06-08 20:32:55 +0200
commit737958da0ef812e2284ccc0c750f3234e6d40567 (patch)
treedb968235946b645d1f4a0e38a9060d647c825c14
downloadaur-737958da0ef812e2284ccc0c750f3234e6d40567.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffea8ff9845f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-d2vsource-git
+ pkgdesc = Plugin for Vapoursynth: d2vsource (GIT version)
+ pkgver = beta7.4.g2859cb6
+ pkgrel = 1
+ url = https://github.com/dwbuiten/d2vsource
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-d2vsource
+ conflicts = vapoursynth-plugin-d2vsource
+ source = git+https://github.com/dwbuiten/d2vsource.git
+ md5sums = SKIP
+
+pkgname = vapoursynth-plugin-d2vsource-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b6943445152
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=d2vsource
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=beta7.4.g2859cb6
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="https://github.com/dwbuiten/${_plug}"
+license=('LGPL2.1')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("git+https://github.com/dwbuiten/${_plug}.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_gitname}"
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ make install
+ install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+}
+