summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-05-29 17:06:37 +0200
committersL1pKn072018-05-29 17:06:37 +0200
commit89175eba757b7ea7d883e6c85f9335de9f9cc67b (patch)
treec6f54fc343b68f26c29f66ce1026a3c293b6150b
parent6fe5e6d61da2a9c58e82019cc7815a9851bd6874 (diff)
downloadaur-89175eba757b7ea7d883e6c85f9335de9f9cc67b.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--ffmpeg4.patch30
3 files changed, 5 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6adf1d01b160..cc88eda744e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 20 21:25:07 UTC 2018
+# Tue May 29 15:06:32 UTC 2018
pkgbase = vapoursynth-plugin-d2vsource-git
pkgdesc = Plugin for Vapoursynth: d2vsource (GIT version)
- pkgver = v1.1.4.g5b5e587
+ pkgver = v1.1.7.g99b10e3
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=166399
arch = i686
@@ -16,9 +16,7 @@ pkgbase = vapoursynth-plugin-d2vsource-git
provides = vapoursynth-plugin-d2vsource
conflicts = vapoursynth-plugin-d2vsource
source = git+https://github.com/dwbuiten/d2vsource.git
- source = ffmpeg4.patch
sha256sums = SKIP
- sha256sums = fe0cc3859a6e30e8bde4d79e78adbc5f315628cdfcc46abb9c38825674009183
pkgname = vapoursynth-plugin-d2vsource-git
diff --git a/PKGBUILD b/PKGBUILD
index 29a0984fc816..dbe49a5be8a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=d2vsource
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.1.4.g5b5e587
+pkgver=v1.1.7.g99b10e3
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -16,12 +16,8 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("git+https://github.com/dwbuiten/${_plug}.git"
- 'ffmpeg4.patch'
- )
-sha256sums=('SKIP'
- 'fe0cc3859a6e30e8bde4d79e78adbc5f315628cdfcc46abb9c38825674009183'
- )
+source=("git+https://github.com/dwbuiten/${_plug}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -31,8 +27,6 @@ pkgver() {
prepare() {
mkdir -p build
- patch -d "${_plug}" -p1 -i "${srcdir}/ffmpeg4.patch"
-
cd "${_plug}"
./autogen.sh
diff --git a/ffmpeg4.patch b/ffmpeg4.patch
deleted file mode 100644
index b03e7ec95aa2..000000000000
--- a/ffmpeg4.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/src/core/d2v.hpp b/src/core/d2v.hpp
-index f87b1a0..ecdae78 100644
---- a/src/core/d2v.hpp
-+++ b/src/core/d2v.hpp
-@@ -68,7 +68,7 @@ static const int idct_algo_conv[8] = {
- FF_IDCT_AUTO,
- FF_IDCT_AUTO,
- FF_IDCT_AUTO,
-- FF_IDCT_XVIDMMX,
-+ FF_IDCT_XVID,
- FF_IDCT_SIMPLEMMX
- };
-
-diff --git a/src/core/decode.cpp b/src/core/decode.cpp
-index b563697..11a0fef 100644
---- a/src/core/decode.cpp
-+++ b/src/core/decode.cpp
-@@ -242,12 +242,6 @@ decodecontext *decodeinit(d2vcontext *dctx, int threads, string& err)
- /* Set the thread count. */
- ret->avctx->thread_count = threads;
-
-- /*
-- * Enable EMU_EDGE so that we can use buffers that are
-- * not padded by 32 pixels.
-- */
-- ret->avctx->flags |= CODEC_FLAG_EMU_EDGE;
--
- /* Use refcounted frames. */
- ret->avctx->refcounted_frames = 1;
-