summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-21 00:58:06 +0100
committerGustavo Alvarez2016-01-21 00:58:06 +0100
commit898625dc72939a56db39e1a2fe1cc2a89c076421 (patch)
treeb0acd28b9890dd380ca8d29427884b4964349954
parentb4f6c37daf238d5ca1c2a05661435dc69399c918 (diff)
downloadaur-898625dc72939a56db39e1a2fe1cc2a89c076421.tar.gz
switch to autotools
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0cd1f0165b6..148fd1a3e49c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jan 17 01:32:06 UTC 2016
+# Wed Jan 20 23:57:50 UTC 2016
pkgbase = vapoursynth-plugin-d2vsource-git
pkgdesc = Plugin for Vapoursynth: d2vsource (GIT version)
- pkgver = beta7.10.ge4a2d98
+ pkgver = beta7.30.g38ec2b7
pkgrel = 1
url = https://github.com/dwbuiten/d2vsource
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 4d623204a192..208e1dbab87f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=d2vsource
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=beta7.10.ge4a2d98
+pkgver=beta7.30.g38ec2b7
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -24,17 +24,22 @@ pkgver() {
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
build() {
cd "${_plug}"
- ./configure --install="${pkgdir}/usr/lib/vapoursynth" \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
make
}
package(){
cd "${_plug}"
- make install
+ make DESTDIR="${pkgdir}" install
install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}