summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:33:34 +0200
committersl1pkn072015-06-08 20:33:34 +0200
commit22ba7fec31dd93986fdf6408691c0a85c71cee30 (patch)
tree22ed402b284f34ca4b86f8b618d6998ff0331f82
downloadaur-22ba7fec31dd93986fdf6408691c0a85c71cee30.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7b61bf6e8fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vapoursynth-plugin-damb-git
+ pkgdesc = Plugin for Vapoursynth: damb (GIT version)
+ pkgver = v3.0.g77a20a5
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171555
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ license = LGPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-damb
+ conflicts = vapoursynth-plugin-damb
+ source = damb::git+https://github.com/dubhater/vapoursynth-damb.git
+ source = http://www.wtfpl.net/txt/copying/copying
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-damb-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72d174d332b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=damb
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v3.0.g77a20a5
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171555"
+license=('custom:WTFPL' 'LGPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git"
+ "http://www.wtfpl.net/txt/copying/copying")
+sha1sums=('SKIP'
+ 'SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_gitname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 ../copying "${pkgdir}/usr/share/licenses/${pkgname}/copying"
+}