summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-02-05 15:53:04 +0100
committerGustavo Alvarez2016-02-05 15:53:04 +0100
commit5ee257beb4708aae5cc73b6a02954d287c907f9a (patch)
treedf6f2e539f389ebdfb07a85c1d1ecb89fc50aa3a
parent22ba7fec31dd93986fdf6408691c0a85c71cee30 (diff)
downloadaur-5ee257beb4708aae5cc73b6a02954d287c907f9a.tar.gz
Add libsndfile to depends=()
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD31
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7b61bf6e8fd..30b95b503cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Fri Feb 5 14:52:32 UTC 2016
pkgbase = vapoursynth-plugin-damb-git
pkgdesc = Plugin for Vapoursynth: damb (GIT version)
pkgver = v3.0.g77a20a5
@@ -9,12 +11,13 @@ pkgbase = vapoursynth-plugin-damb-git
license = LGPL
makedepends = git
depends = vapoursynth
+ depends = libsndfile
provides = vapoursynth-plugin-damb
conflicts = vapoursynth-plugin-damb
source = damb::git+https://github.com/dubhater/vapoursynth-damb.git
- source = http://www.wtfpl.net/txt/copying/copying
- sha1sums = SKIP
+ source = COPYING::http://www.wtfpl.net/txt/copying/copying
sha1sums = SKIP
+ sha1sums = 337ece375beddfdb7392699fd00eb9b3e823d03f
pkgname = vapoursynth-plugin-damb-git
diff --git a/PKGBUILD b/PKGBUILD
index 72d174d332b3..382741db9514 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,33 +6,40 @@ pkgver=v3.0.g77a20a5
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
-url="http://forum.doom9.org/showthread.php?t=171555"
+url='http://forum.doom9.org/showthread.php?t=171555'
license=('custom:WTFPL' 'LGPL')
-depends=('vapoursynth')
+depends=('vapoursynth'
+ 'libsndfile'
+ )
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git"
- "http://www.wtfpl.net/txt/copying/copying")
+ 'COPYING::http://www.wtfpl.net/txt/copying/copying')
sha1sums=('SKIP'
- 'SKIP')
-_gitname="${_plug}"
+ '337ece375beddfdb7392699fd00eb9b3e823d03f')
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-build() {
- cd "${_gitname}"
+prepare() {
+ cd "${_plug}"
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
make
}
package(){
- cd "${_gitname}"
+ cd "${_plug}"
make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
- install -Dm644 ../copying "${pkgdir}/usr/share/licenses/${pkgname}/copying"
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ install -Dm644 ../COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}