summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:53:24 +0100
committersL1pKn072019-03-02 20:53:24 +0100
commitbc36801da8584ffa56331ac39a8db84c43214326 (patch)
tree09248765da40abe6d021f59f9ecff87cb5fbca51
parent4449c35060483b1bdc6ee2397103d1a80885c362 (diff)
downloadaur-bc36801da8584ffa56331ac39a8db84c43214326.tar.gz
bump
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34366bd59562..9e7cbd3998bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Mar 1 15:08:37 UTC 2019
+# Sat Mar 2 19:53:24 UTC 2019
pkgbase = vapoursynth-plugin-damb-git
pkgdesc = Plugin for Vapoursynth: damb (GIT version)
pkgver = v3.0.g77a20a5
diff --git a/PKGBUILD b/PKGBUILD
index 9166ad858e0f..0e87d1a15908 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,13 +29,15 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth
@@ -43,9 +45,8 @@ build() {
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
- install -Dm644 ../COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}