summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-06-16 15:41:33 +0200
committersL1pKn072018-06-16 15:41:33 +0200
commit62f5fcb1d840ef585021b49f059d663e99f9e246 (patch)
tree524066d49a39791ff3109a40595a9e9895817a6c
downloadaur-62f5fcb1d840ef585021b49f059d663e99f9e246.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ff06b27e091
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jun 16 13:41:33 UTC 2018
+pkgbase = vapoursynth-plugin-decross-git
+ pkgdesc = Plugin for Vapoursynth: decross (GIT version)
+ pkgver = v1.0.g39485ce
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=175527
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-decross
+ conflicts = vapoursynth-plugin-decross
+ source = decross::git+https://github.com/dubhater/vapoursynth-decross.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-decross-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2deeafb33f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=decross
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.g39485ce
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url="https://forum.doom9.org/showthread.php?t=175527"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+}
+
+build() {
+ ninja -C build
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}