summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-08 18:40:36 +0100
committersL1pKn072019-02-08 18:40:36 +0100
commit8c5c13058ed9372e2ce679d2a768aa9b5ecb80b7 (patch)
tree3b857c259122a56d724948c2e7f9957c0702cfed
downloadaur-8c5c13058ed9372e2ce679d2a768aa9b5ecb80b7.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ab21d70a829
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 8 17:40:36 UTC 2019
+pkgbase = vapoursynth-plugin-dedot-git
+ pkgdesc = Plugin for Vapoursynth: dedot (GIT version)
+ pkgver = v1.0.g7da00d7
+ pkgrel = 1
+ url = https://github.com/dubhater/dedot
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-dedot
+ conflicts = vapoursynth-plugin-dedot
+ source = dedot::git+https://github.com/dubhater/vapoursynth-dedot.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-dedot-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbf4dae44b4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=dedot
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.g7da00d7
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url="https://github.com/dubhater/dedot"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}