summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-11-27 20:18:11 +0100
committersl1pkn072015-11-27 20:18:11 +0100
commit549b9f8446ca8fc1d648c840866e9779b699c9c5 (patch)
treee2e29ce79b701e1416d9fb81ec2e3d96c8ea1397
parentcafdc39a9cb993784e720c45156ba88ff0cb2696 (diff)
downloadaur-549b9f8446ca8fc1d648c840866e9779b699c9c5.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43acf58532ca..9300c0534f81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,10 @@ pkgbase = vapoursynth-plugin-delogo-git
url = http://forum.doom9.org/showthread.php?t=171252
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = git
depends = vapoursynth
+ depends = gcc-libs
provides = vapoursynth-plugin-delogo
conflicts = vapoursynth-plugin-delogo
source = delogo::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-DeLogo.git
diff --git a/PKGBUILD b/PKGBUILD
index e4adc8791271..db0d21d3e996 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=delogo
pkgname=vapoursynth-plugin-${_plug}-git
@@ -7,8 +7,10 @@ pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
url='http://forum.doom9.org/showthread.php?t=171252'
-license=('GPL')
-depends=('vapoursynth')
+license=('GPL2')
+depends=('vapoursynth'
+ 'gcc-libs'
+ )
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -23,7 +25,7 @@ pkgver() {
build() {
cd "${_plug}"
./configure --install="${pkgdir}/usr/lib/vapoursynth" \
- --extra-cxxflags="${CXXFLAGS}" \
+ --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
--extra-ldflags="${LDFLAGS}"
make
}