summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-10-19 18:13:40 +0200
committersL1pKn072022-10-19 18:13:40 +0200
commit2e5cff3409659f49578dc745352cc54785166302 (patch)
tree41dfec5473752169b4799fce53ce348f9cc35211
parent37880571260f63356900ee5b7c2b4db6ed28332f (diff)
downloadaur-2e5cff3409659f49578dc745352cc54785166302.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f77ab163641e..70989f822db3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-depan-git
pkgdesc = Plugin for Vapoursynth: depan. (GIT Version)
- pkgver = 1.0.ge248fa9
+ pkgver = r1.0.g2f05589
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=173505
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = vapoursynth-plugin-depan-git
provides = vapoursynth-plugin-depan
conflicts = vapoursynth-plugin-depan
options = debug
- source = https://www.dropbox.com/s/d72bougsis2se58/vapoursynth-depan-1.tar.gz
- sha256sums = bca09707018b2011e6300900006d71b21b2290c4bd8ba34b27c844d6ff03b6d6
+ source = depan::git+https://github.com/Vapoursynth-Plugins-Gitify/DePan.git
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-depan-git
diff --git a/PKGBUILD b/PKGBUILD
index e17f2e03dd12..d571e04af598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=depan
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=1.0.ge248fa9
+pkgver=r1.0.g2f05589
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug}. (GIT Version)"
arch=('x86_64')
@@ -14,22 +14,21 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-#source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/DePan.git")
-source=('https://www.dropbox.com/s/d72bougsis2se58/vapoursynth-depan-1.tar.gz')
-#sha256sums=('SKIP')
-sha256sums=('bca09707018b2011e6300900006d71b21b2290c4bd8ba34b27c844d6ff03b6d6')
+source=("${_plug}::git+https://github.com/Vapoursynth-Plugins-Gitify/DePan.git")
+sha256sums=('SKIP')
options=('debug')
pkgver() {
- #cd "${_plug}"
- #points to latest knowed commit
- echo "1.0.ge248fa9"
- #echo "$(git describe --long --tags | tr - .)"
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ chmod +x "${_plug}/configure"
}
build() {
- #cd "${_plug}"
- cd VapourSynth-DePan-r1
+ cd "${_plug}"
./configure \
--install="${pkgdir}/usr/lib/vapoursynth" \
--extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
@@ -39,8 +38,7 @@ build() {
}
package() {
- cd VapourSynth-DePan-r1
- #cd "${_plug}"
+ cd "${_plug}"
make install
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}