summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-08 20:25:55 +0100
committersL1pKn072019-02-08 20:25:55 +0100
commit2ee7c75b056a1028521c22185189f7c6e4ffc639 (patch)
treeb8b37236fad30c3fbabb30354d53ac8c9060504b
parent3e61fda478db66a6b27240cf45df332e28402b07 (diff)
downloadaur-2ee7c75b056a1028521c22185189f7c6e4ffc639.tar.gz
uptream is gone, switchs to last knowed snapshot
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3418bdc03b10..def095841c09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat May 21 12:54:32 UTC 2016
+# Fri Feb 8 19:25:03 UTC 2019
pkgbase = vapoursynth-plugin-depan-git
pkgdesc = Plugin for Vapoursynth: depan. (GIT Version)
pkgver = r1.0.ge248fa9
@@ -13,8 +13,8 @@ pkgbase = vapoursynth-plugin-depan-git
depends = fftw
provides = vapoursynth-plugin-depan
conflicts = vapoursynth-plugin-depan
- source = depan::git+https://github.com/HomeOfVapourSynthEvolution/DePan.git
- sha1sums = SKIP
+ source = https://www.dropbox.com/s/d72bougsis2se58/vapoursynth-depan-1.tar.gz
+ sha256sums = bca09707018b2011e6300900006d71b21b2290c4bd8ba34b27c844d6ff03b6d6
pkgname = vapoursynth-plugin-depan-git
diff --git a/PKGBUILD b/PKGBUILD
index 47ae3f792ce1..240394bcde29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,25 +14,33 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/DePan.git")
-sha1sums=('SKIP')
+#source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/DePan.git")
+source=('https://www.dropbox.com/s/d72bougsis2se58/vapoursynth-depan-1.tar.gz')
+#sha256sums=('SKIP')
+sha256sums=('bca09707018b2011e6300900006d71b21b2290c4bd8ba34b27c844d6ff03b6d6')
+
pkgver() {
- cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ #cd "${_plug}"
+ #points to latest knowed commit
+ echo "r1.0.ge248fa9"
+ #echo "$(git describe --long --tags | tr - .)"
}
build() {
- cd "${_plug}"
+ #cd "${_plug}"
+ cd VapourSynth-DePan-r1
./configure \
--install="${pkgdir}/usr/lib/vapoursynth" \
--extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
--extra-ldflags="${LDFLAGS}"
+
make
}
-package(){
- cd "${_plug}"
+package() {
+ cd VapourSynth-DePan-r1
+ #cd "${_plug}"
make install
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}