summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-12-16 20:09:01 +0100
committersL1pKn072017-12-16 20:09:01 +0100
commit880f88cc91af6cb03a86213e8154d0c270d4dc38 (patch)
tree68a303a9c12d9a5f411722c5262b6786e9881e4c
parentc4cf29edbde23938f26b1a32033514cfb11f1fd0 (diff)
downloadaur-880f88cc91af6cb03a86213e8154d0c270d4dc38.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 827f3ea50b08..7c2315e0909e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Mar 15 17:40:33 UTC 2016
+# Sat Dec 16 19:08:56 UTC 2017
pkgbase = vapoursynth-plugin-dfttest-git
pkgdesc = Plugin for Vapoursynth: dfttest (GIT version)
- pkgver = r3.9.gbe43cc7
+ pkgver = r3.24.g3c741f4
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171678
arch = i686
@@ -14,7 +14,7 @@ pkgbase = vapoursynth-plugin-dfttest-git
provides = vapoursynth-plugin-dfttest
conflicts = vapoursynth-plugin-dfttest
source = dfttest::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-DFTTest.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-dfttest-git
diff --git a/PKGBUILD b/PKGBUILD
index a650bb7da41c..8061d37b685a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=dfttest
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r3.9.gbe43cc7
+pkgver=r3.24.g3c741f4
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -15,24 +15,29 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-DFTTest.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
build() {
cd "${_plug}"
./configure \
- --install="${pkgdir}/usr/lib/vapoursynth" \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
make
}
package(){
cd "${_plug}"
- make install
+ make DESTDIR="${pkgdir}" install
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}