summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWoofinaS2022-10-18 16:37:52 -0400
committerWoofinaS2022-10-18 16:37:52 -0400
commitf13a1d930543bf4d6d0c038e134b3a77068b2fa3 (patch)
treea452333d26aa5d0e3e72d4aeca80631b2987250c
parent9b33e4701235649397f035b088a03ce905e1ceb1 (diff)
downloadaur-f13a1d930543bf4d6d0c038e134b3a77068b2fa3.tar.gz
updated pkgbuild to conform with full build pkg
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD17
2 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f1a3925768c..aff4618f032c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,6 @@ pkgbase = vapoursynth-plugin-dfttest2-cpu-git
makedepends = cmake
makedepends = ninja
makedepends = gcc11
- makedepends = unzip
depends = vapoursynth
provides = vapoursynth-plugin-dfttest2-cpu
conflicts = vapoursynth-plugin-dfttest2
diff --git a/PKGBUILD b/PKGBUILD
index 5722248dc2ae..c33f67523174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,6 @@
# Removed cuda as a requirement
# Removed undeeded cmake flags
# Removed c compiler flags overide
-# Moved build folder to inside clone
_plug=dfttest2
pkgname=vapoursynth-plugin-dfttest2-cpu-git
@@ -18,7 +17,7 @@ arch=('x86_64')
url='https://github.com/AmusementClub/vs-dfttest2'
license=('GPL2')
depends=('vapoursynth')
-makedepends=('git' 'cmake' 'ninja' 'gcc11' 'unzip')
+makedepends=('git' 'cmake' 'ninja' 'gcc11')
provides=("vapoursynth-plugin-dfttest2-cpu")
conflicts=("vapoursynth-plugin-dfttest2" "vapoursynth-plugin-dfttest2-git")
source=("${_plug}::git+https://github.com/AmusementClub/vs-dfttest2")
@@ -33,34 +32,28 @@ pkgver() {
}
prepare() {
- # Download vector class library
cd "${_plug}"
-
- rm -rf vectorclass version2*
- wget -q -O vcl.zip https://github.com/vectorclass/version2/archive/refs/tags/v2.01.04.zip
- unzip -q vcl.zip
- mv version2*/ vectorclass
+ git submodule update --init --recursive
}
build() {
# This is based on what the project's CI is doing
- cd "${_plug}"
-
export CXX=g++-11
cmake \
-B "build" \
+ -S "${_plug}" \
-G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_COMPILER="${CXX}" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS_RELEASE="-ffast-math -march=native" \
-DENABLE_CUDA=0 \
- -DVCL_HOME="$(pwd)/vectorclass" \
-Wno-dev
cmake --build "build" --config Release
}
package() {
- DESTDIR="$pkgdir" cmake --install "${_plug}/build"
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"