summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:34:00 +0200
committersl1pkn072015-06-08 20:34:00 +0200
commit4734c53f8d483f580006bb1d0c05610cd5ab8be1 (patch)
treed797b654215ecfd28286357162f478b49b2e6d10
downloadaur-4734c53f8d483f580006bb1d0c05610cd5ab8be1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5107e504d3f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-dither-git
+ pkgdesc = Plugin for Vapoursynth: dither (GIT version)
+ pkgver = 20150223.0f209b6
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171525
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ depends = vapoursynth-plugin-fmtconv
+ provides = vapoursynth-plugin-dither
+ conflicts = vapoursynth-plugin-dither
+ source = dither::git+https://github.com/IFeelBloated/VaporSynth-Functions.git
+ md5sums = SKIP
+
+pkgname = vapoursynth-plugin-dither-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa36ff678a5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=dither
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=20150223.0f209b6
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='http://forum.doom9.org/showthread.php?t=171525'
+license=('GPL')
+depends=('vapoursynth' 'vapoursynth-plugin-fmtconv')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/IFeelBloated/VaporSynth-Functions.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_gitname}"
+ #echo "$(git describe --long --tags | tr - .)"
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+package(){
+ cd "${_gitname}"
+ install -Dm644 Dither.py "${pkgdir}${_sites_packages}/Dither.py"
+}
+