summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 23:10:26 +0200
committerGustavo Alvarez2016-10-19 23:10:26 +0200
commit55a1efc954e4ecf3b299492f6e24646ed1c0398e (patch)
treeeca19d20a360f47b45a74b5ac2009e50ccc58aa0
parentd9567c9b6cd661d52d5bc16e9d71db2e6b560bab (diff)
downloadaur-55a1efc954e4ecf3b299492f6e24646ed1c0398e.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cdcbf476a79..71a3d1b9eb5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Oct 19 21:10:21 UTC 2016
pkgbase = vapoursynth-plugin-dither-git
pkgdesc = Plugin for Vapoursynth: dither (GIT version)
pkgver = r19.0f209b6
@@ -11,7 +13,7 @@ pkgbase = vapoursynth-plugin-dither-git
provides = vapoursynth-plugin-dither
conflicts = vapoursynth-plugin-dither
source = dither::git+https://github.com/IFeelBloated/VaporSynth-Functions.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-dither-git
diff --git a/PKGBUILD b/PKGBUILD
index 1754e883742b..5630e9b971cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,16 @@ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
url='http://forum.doom9.org/showthread.php?t=171525'
license=('GPL')
-depends=('vapoursynth' 'vapoursynth-plugin-fmtconv')
+depends=('vapoursynth'
+ 'vapoursynth-plugin-fmtconv'
+ )
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/IFeelBloated/VaporSynth-Functions.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -24,6 +26,8 @@ pkgver() {
}
package(){
- install -Dm644 "${_plug}/Dither.py" "${pkgdir}${_sites_packages}/Dither.py"
+ install -Dm644 "${_plug}/Dither.py" "${pkgdir}${_site_packages}/Dither.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/Dither.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/Dither.py"
}