summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-09-25 17:01:43 +0200
committersl1pkn072015-09-25 17:01:43 +0200
commitd9567c9b6cd661d52d5bc16e9d71db2e6b560bab (patch)
treebbb572ae8b9d8e00e5b577a89536e3fcb73f5390
parent4734c53f8d483f580006bb1d0c05610cd5ab8be1 (diff)
downloadaur-d9567c9b6cd661d52d5bc16e9d71db2e6b560bab.tar.gz
Update pkgver() function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5107e504d3f8..0cdcbf476a79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-dither-git
pkgdesc = Plugin for Vapoursynth: dither (GIT version)
- pkgver = 20150223.0f209b6
+ pkgver = r19.0f209b6
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171525
arch = any
@@ -11,7 +11,7 @@ pkgbase = vapoursynth-plugin-dither-git
provides = vapoursynth-plugin-dither
conflicts = vapoursynth-plugin-dither
source = dither::git+https://github.com/IFeelBloated/VaporSynth-Functions.git
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = vapoursynth-plugin-dither-git
diff --git a/PKGBUILD b/PKGBUILD
index fa36ff678a5d..1754e883742b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=dither
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=20150223.0f209b6
+pkgver=r19.0f209b6
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
@@ -13,18 +13,17 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/IFeelBloated/VaporSynth-Functions.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
+
_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
#echo "$(git describe --long --tags | tr - .)"
- echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package(){
- cd "${_gitname}"
- install -Dm644 Dither.py "${pkgdir}${_sites_packages}/Dither.py"
+ install -Dm644 "${_plug}/Dither.py" "${pkgdir}${_sites_packages}/Dither.py"
}