summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-06-09 22:36:31 +0200
committersL1pKn072021-06-09 22:36:31 +0200
commit6bc22fa35052e9d36b7cc3e63baf53c9bbb2a38f (patch)
tree7b3df475b3abb7338728126dc79087012334a7e8
parentad54deb23d8bb3ceffb6fcec0af7706c54fb63b0 (diff)
downloadaur-6bc22fa35052e9d36b7cc3e63baf53c9bbb2a38f.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d132b75beddd..0d3b2856d4ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-# Generated by mksrcinfo v8
-# Thu Apr 11 15:40:12 UTC 2019
pkgbase = vapoursynth-plugin-dpid-git
pkgdesc = Plugin for Vapoursynth: dpid (GIT version)
- pkgver = r3.10.g53194f1
+ pkgver = r4.10.g9eda70b
pkgrel = 1
url = https://github.com/WolframRhodium/VapourSynth-dpid
arch = x86_64
license = GPL
makedepends = git
+ makedepends = meson
depends = vapoursynth
depends = cuda
provides = vapoursynth-plugin-dpid
@@ -16,4 +15,3 @@ pkgbase = vapoursynth-plugin-dpid-git
sha256sums = SKIP
pkgname = vapoursynth-plugin-dpid-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 10514cbd2879..ff53b747d67d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=dpid
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r3.10.g53194f1
+pkgver=r4.10.g9eda70b
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -12,6 +12,7 @@ depends=('vapoursynth'
'cuda'
)
makedepends=('git'
+ 'meson'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -23,12 +24,21 @@ pkgver() {
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ mkdir -p build
+
+}
+
build() {
- make -C "${_plug}/Source"
+ cd build
+ arch-meson "../${_plug}/Source" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
}
package(){
- make -C "${_plug}/Source" PREFIX="${pkgdir}/usr/lib/vapoursynth" install
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}