summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-07 17:10:33 +0200
committersL1pKn072019-04-07 17:10:33 +0200
commit97cb7f21a1d7484a78072ede3ea183c70e92184b (patch)
tree25ca4812934e621e72a77d45375585a9f26fdee2
parentbadfabcab905a48750baade80e2e13a68d855842 (diff)
downloadaur-97cb7f21a1d7484a78072ede3ea183c70e92184b.tar.gz
bump
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--esee27
3 files changed, 28 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bf0faa0086c..89ce8419be47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Apr 7 13:50:59 UTC 2019
+# Sun Apr 7 15:10:27 UTC 2019
pkgbase = vapoursynth-plugin-dpid-git
pkgdesc = Plugin for Vapoursynth: dpid (GIT version)
pkgver = r3.8.g7771a30
diff --git a/PKGBUILD b/PKGBUILD
index d66396755fd1..fb69a395ae60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,8 @@ license=('GPL')
depends=('vapoursynth'
'cuda'
)
-makedepends=('git')
+makedepends=('git'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/WolframRhodium/VapourSynth-dpid.git"
diff --git a/esee b/esee
index a0a93f06d0af..3a1c3baf61a0 100644
--- a/esee
+++ b/esee
@@ -1,8 +1,31 @@
diff --git a/Source/Makefile b/Source/Makefile
-index b670ac2..b18c520 100644
+index b670ac2..634c128 100644
--- a/Source/Makefile
+++ b/Source/Makefile
-@@ -25,8 +25,7 @@ kernel16.o: kernel16.cu
+@@ -6,10 +6,11 @@ LIBS = cudart
+ INCLUDE = /opt/cuda/include /usr/include
+ TARGET ?= libdpid.so
+ PREFIX ?= /usr/local/lib/vapoursynth
++NVCC = /opt/cuda/bin/nvcc
+
+ $(TARGET): dpid.o kernel8.o kernel16.o
+ @echo "Linking target..."
+- @nvcc -shared -m64 $(CUFLAGS) $(addprefix -l,$(LIBS)) $(addprefix -L,$(LIBDIRS)) dpid.o kernel8.o kernel16.o -o $(TARGET)
++ @$(NVCC) -shared -m64 $(CUFLAGS) $(addprefix -l,$(LIBS)) $(addprefix -L,$(LIBDIRS)) dpid.o kernel8.o kernel16.o -o $(TARGET)
+
+ dpid.o: dpid.cpp dpid.h
+ @echo "Compiling dpid.cpp ..."
+@@ -17,16 +18,15 @@ dpid.o: dpid.cpp dpid.h
+
+ kernel8.o: kernel8.cu
+ @echo "Compiling kernel8.cu ..."
+- @nvcc $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
++ @$(NVCC) $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
+
+ kernel16.o: kernel16.cu
+ @echo "Compiling kernel16.cu ..."
+- @nvcc $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
++ @$(NVCC) $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
install: $(TARGET)
@echo "Installing..."