summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-11 17:40:17 +0200
committersL1pKn072019-04-11 17:40:17 +0200
commitad54deb23d8bb3ceffb6fcec0af7706c54fb63b0 (patch)
tree83f81b85ecc1547be2962e6f67a329f98e785ba8
parentd9979f58c23f7d8b2930d709e15b5db8d60f7d42 (diff)
downloadaur-ad54deb23d8bb3ceffb6fcec0af7706c54fb63b0.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
-rw-r--r--esee31
4 files changed, 3 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d0f853354da..d132b75beddd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Apr 7 17:13:14 UTC 2019
+# Thu Apr 11 15:40:12 UTC 2019
pkgbase = vapoursynth-plugin-dpid-git
pkgdesc = Plugin for Vapoursynth: dpid (GIT version)
pkgver = r3.10.g53194f1
@@ -13,8 +13,6 @@ pkgbase = vapoursynth-plugin-dpid-git
provides = vapoursynth-plugin-dpid
conflicts = vapoursynth-plugin-dpid
source = dpid::git+https://github.com/WolframRhodium/VapourSynth-dpid.git
- source = esee
- sha256sums = SKIP
sha256sums = SKIP
pkgname = vapoursynth-plugin-dpid-git
diff --git a/.gitignore b/.gitignore
index fce6edeefba2..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-!esee
diff --git a/PKGBUILD b/PKGBUILD
index 033dec6fb7fe..10514cbd2879 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,25 +15,14 @@ makedepends=('git'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/WolframRhodium/VapourSynth-dpid.git"
- 'esee'
- )
-sha256sums=('SKIP'
- 'SKIP'
- )
+source=("${_plug}::git+https://github.com/WolframRhodium/VapourSynth-dpid.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- cd "${_plug}/Source"
-
- patch -p2 -i "${srcdir}/esee"
-}
-
-
build() {
make -C "${_plug}/Source"
}
diff --git a/esee b/esee
deleted file mode 100644
index ef276024b762..000000000000
--- a/esee
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/Source/Makefile b/Source/Makefile
-index c8d9383..3964b85 100644
---- a/Source/Makefile
-+++ b/Source/Makefile
-@@ -6,10 +6,11 @@ LIBS = cudart
- INCLUDE = /opt/cuda/include /usr/include
- TARGET ?= libdpid.so
- PREFIX ?= /usr/local/lib/vapoursynth
-+NVCC = /opt/cuda/bin/nvcc
-
- $(TARGET): dpid.o kernel8.o kernel16.o
- @echo "Linking target..."
-- @nvcc -shared -m64 $(CUFLAGS) $(addprefix -l,$(LIBS)) $(addprefix -L,$(LIBDIRS)) dpid.o kernel8.o kernel16.o -o $(TARGET)
-+ @$(NVCC) -shared -m64 $(CUFLAGS) $(addprefix -l,$(LIBS)) $(addprefix -L,$(LIBDIRS)) dpid.o kernel8.o kernel16.o -o $(TARGET)
-
- dpid.o: dpid.cpp dpid.h
- @echo "Compiling dpid.cpp ..."
-@@ -17,11 +18,11 @@ dpid.o: dpid.cpp dpid.h
-
- kernel8.o: kernel8.cu
- @echo "Compiling kernel8.cu ..."
-- @nvcc $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
-+ @$(NVCC) $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
-
- kernel16.o: kernel16.cu
- @echo "Compiling kernel16.cu ..."
-- @nvcc $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
-+ @$(NVCC) $(addprefix -I,$(INCLUDE)) -m64 -c $(CUFLAGS) $< -o $@
-
- install: $(TARGET)
- @echo "Installing..."