summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-10-27 03:10:17 +0100
committersL1pKn072019-10-27 03:10:17 +0100
commit8d8d4247b04fe0a073bf7ea0b9e9d0cc1e3643fd (patch)
tree5679e3048f9db65bb25ffa4b27e114c93bc2b119
downloadaur-8d8d4247b04fe0a073bf7ea0b9e9d0cc1e3643fd.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d684285ad30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vapoursynth-plugin-edgefixer-git
+ pkgdesc = Plugin for Vapoursynth: edgefixer
+ pkgver = r1.8.gfb00a01
+ pkgrel = 1
+ url = https://github.com/sekrit-twc/znedi3
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-edgefixer
+ conflicts = vapoursynth-plugin-edgefixer
+ source = edgefixer::git+https://github.com/sekrit-twc/EdgeFixer.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-edgefixer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c9f82f90044
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Mikuro Kagamine <mikurok@forgecrushing.com>
+
+_plug=edgefixer
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.8.gfb00a01
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('x86_64')
+url='https://github.com/sekrit-twc/znedi3'
+license=('GPL2')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/sekrit-twc/EdgeFixer.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+
+ # use system vapoursynth headers
+ rm -fr EdgeFixer/VapourSynth.h
+ rm -fr EdgeFixer/VSHelper.h
+
+ pwd
+
+ sed -e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
+ -e 's|"VSHelper.h"|<VSHelper.h>|g' \
+ -i EdgeFixer/vsplugin.c
+
+ echo "all:
+ gcc -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. -I./src/imagine -I./extra $(pkg-config --cflags vapoursynth) -o vsplugin.o EdgeFixer/vsplugin.c
+ gcc -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. -I./src/imagine -I./extra $(pkg-config --cflags vapoursynth) -o edgefixer.o EdgeFixer/edgefixer.c
+
+ gcc -shared -fPIC ${LDFLAGS} -o libvs${_plug}.so vsplugin.o edgefixer.o"> Makefile
+}
+
+build() {
+ make -C "${_plug}"
+}
+
+package(){
+ install -Dm755 "${_plug}/libvs${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/libvs${_plug}.so"
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}