summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:34:10 +0200
committersl1pkn072015-06-08 20:34:10 +0200
commit94517caea2de9c9761ae20bbe6205e6e489203c1 (patch)
tree77fb2644ecd30b2b4185c542d0cbeb4d62bdcc27
downloadaur-94517caea2de9c9761ae20bbe6205e6e489203c1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90fe164dd811
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-eedi2-git
+ pkgdesc = Plugin for Vapoursynth: eedi2 (GIT version)
+ pkgver = r6.0.g6e71879
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171136
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-eedi2
+ conflicts = vapoursynth-plugin-eedi2
+ source = eedi2::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI2.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-eedi2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea322140b0b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=eedi2
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r6.0.g6e71879
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171136"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI2.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}