summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-03-10 15:28:17 +0100
committersL1pKn072017-03-10 15:28:17 +0100
commit9713a38c697979e168b4717cdcdf9f1c5eb71084 (patch)
tree6453af1eb69b5b0eb6f7faffb9199feeca6ff5ec
parentcd946423906825e424e00404d42f42ce85ae9a44 (diff)
downloadaur-9713a38c697979e168b4717cdcdf9f1c5eb71084.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6347145ced70..446ecbc510e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 20:45:48 UTC 2015
+# Fri Mar 10 14:28:11 UTC 2017
pkgbase = vapoursynth-plugin-eedi2-git
pkgdesc = Plugin for Vapoursynth: eedi2 (GIT version)
- pkgver = r6.4.ga7fcb5c
+ pkgver = r7.1.g17f2fde
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171136
arch = i686
@@ -13,7 +13,7 @@ pkgbase = vapoursynth-plugin-eedi2-git
provides = vapoursynth-plugin-eedi2
conflicts = vapoursynth-plugin-eedi2
source = eedi2::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI2.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-eedi2-git
diff --git a/PKGBUILD b/PKGBUILD
index 7d6b4e65002b..787421cd1798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=eedi2
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r6.4.ga7fcb5c
+pkgver=r7.1.g17f2fde
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -13,23 +13,29 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI2.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
build() {
cd "${_plug}"
- ./configure --install="${pkgdir}/usr/lib/vapoursynth" \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
make
}
package(){
cd "${_plug}"
- make install
+ make DESTDIR="${pkgdir}" install
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}