summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-08 19:24:28 +0100
committersL1pKn072019-02-08 19:24:28 +0100
commitbf667e3db722889e81c1bbb266af54d18f62a2ec (patch)
treebfba3f927322da60f78c2343b76f05a966564be7
parent9713a38c697979e168b4717cdcdf9f1c5eb71084 (diff)
downloadaur-bf667e3db722889e81c1bbb266af54d18f62a2ec.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 446ecbc510e7..404284e950bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Fri Mar 10 14:28:11 UTC 2017
+# Fri Feb 8 18:24:24 UTC 2019
pkgbase = vapoursynth-plugin-eedi2-git
pkgdesc = Plugin for Vapoursynth: eedi2 (GIT version)
- pkgver = r7.1.g17f2fde
+ pkgver = r7.1.0.g9d82bc5
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171136
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ makedepends = meson
depends = vapoursynth
provides = vapoursynth-plugin-eedi2
conflicts = vapoursynth-plugin-eedi2
diff --git a/PKGBUILD b/PKGBUILD
index 787421cd1798..aa638cd5bfa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
_plug=eedi2
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r7.1.g17f2fde
+pkgver=r7.1.0.g9d82bc5
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
url='http://forum.doom9.org/showthread.php?t=171136'
license=('GPL')
depends=('vapoursynth')
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI2.git")
@@ -21,21 +23,19 @@ pkgver() {
}
prepare() {
- cd "${_plug}"
- ./autogen.sh
+ mkdir -p build
}
build() {
- cd "${_plug}"
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib/vapoursynth
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
- make
+ ninja
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}