summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-06 21:40:41 +0100
committersL1pKn072022-02-06 21:40:41 +0100
commit3e4313f3660942322e76b30f17617e13e07adb35 (patch)
tree569371272f4ee8876c3bbf96a0a6cfe260d5a93b
parent55d8a3a3152e30cb9c2a8bd73b1f29efa8d5feee (diff)
downloadaur-3e4313f3660942322e76b30f17617e13e07adb35.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5da0b214715..89c2b800aa35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = vapoursynth-plugin-ffspectrum-git
pkgdesc = Plugin for Vapoursynth: ffspectrum (GIT version)
- pkgver = r1.1.g0fe5160
+ pkgver = r1.5.g6326b2e
pkgrel = 1
url = https://github.com/Beatrice-Raws/FFTSpectrum
arch = x86_64
license = GPL
makedepends = git
+ makedepends = meson
depends = vapoursynth
+ depends = fftw
provides = vapoursynth-plugin-ffspectrum
conflicts = vapoursynth-plugin-ffspectrum
source = ffspectrum::git+https://github.com/Beatrice-Raws/FFTSpectrum.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-ffspectrum-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4faa79a9af2e..c8357455ea62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,18 @@
_plug=ffspectrum
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r1.1.g0fe5160
+pkgver=r1.5.g6326b2e
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Beatrice-Raws/FFTSpectrum'
license=('GPL')
-depends=('vapoursynth')
-makedepends=('git')
+depends=('vapoursynth'
+ 'fftw'
+ )
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Beatrice-Raws/FFTSpectrum.git")
@@ -20,21 +24,20 @@ pkgver() {
echo "$(git describe --long --tags | tr - .)"
}
-prepare(){
- cd "${_plug}"
-
- echo "all:
- gcc -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o FFTSpectrum.o FFTSpectrum.c
- gcc -shared -fPIC ${LDFLAGS} -o lib${_plug}.so FFTSpectrum.o" > Makefile
+prepare() {
+ mkdir -p build
}
build() {
- make -C "${_plug}"
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
}
-package() {
- cd "${_plug}"
- install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}