summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-09 14:05:08 +0100
committersL1pKn072020-03-09 14:05:08 +0100
commit55d8a3a3152e30cb9c2a8bd73b1f29efa8d5feee (patch)
tree54efc65d0ef050c39addb0e7e879a09fa56007e9
downloadaur-55d8a3a3152e30cb9c2a8bd73b1f29efa8d5feee.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5da0b214715
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vapoursynth-plugin-ffspectrum-git
+ pkgdesc = Plugin for Vapoursynth: ffspectrum (GIT version)
+ pkgver = r1.1.g0fe5160
+ pkgrel = 1
+ url = https://github.com/Beatrice-Raws/FFTSpectrum
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-ffspectrum
+ conflicts = vapoursynth-plugin-ffspectrum
+ source = ffspectrum::git+https://github.com/Beatrice-Raws/FFTSpectrum.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-ffspectrum-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4faa79a9af2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=ffspectrum
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.1.g0fe5160
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Beatrice-Raws/FFTSpectrum'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Beatrice-Raws/FFTSpectrum.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare(){
+ cd "${_plug}"
+
+ echo "all:
+ gcc -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o FFTSpectrum.o FFTSpectrum.c
+ gcc -shared -fPIC ${LDFLAGS} -o lib${_plug}.so FFTSpectrum.o" > Makefile
+}
+
+build() {
+ make -C "${_plug}"
+}
+
+package() {
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}