summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-06 21:48:13 +0100
committersL1pKn072022-02-06 21:48:13 +0100
commitcfa835b869b77f5feffc507fdfb378f5e9dcc4f8 (patch)
treed54882a8229bcf456bc426a2272b9e646cc78932
parentf748d3b7e77452b5b6a73236a228828b07ca4d25 (diff)
downloadaur-cfa835b869b77f5feffc507fdfb378f5e9dcc4f8.tar.gz
Initial commit
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD30
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13f11ebc2888..e22ed3b3956c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = vapoursynth-plugin-fftspectrum-git
pkgdesc = Plugin for Vapoursynth: fftspectrum (GIT version)
- pkgver = r1.1.g0fe5160
- pkgrel = 2
+ pkgver = r1.5.g6326b2e
+ pkgrel = 1
url = https://github.com/Beatrice-Raws/FFTSpectrum
arch = x86_64
license = GPL
makedepends = git
+ makedepends = meson
depends = vapoursynth
depends = fftw
provides = vapoursynth-plugin-fftspectrum
diff --git a/PKGBUILD b/PKGBUILD
index 000f221ee26c..bb927ba1769f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_plug=fftspectrum
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r1.1.g0fe5160
-pkgrel=2
+pkgver=r1.5.g6326b2e
+pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Beatrice-Raws/FFTSpectrum'
@@ -11,7 +11,9 @@ license=('GPL')
depends=('vapoursynth'
'fftw'
)
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Beatrice-Raws/FFTSpectrum.git")
@@ -23,25 +25,19 @@ pkgver() {
}
prepare() {
- cd "${_plug}"
-
- sed -e 's|"vapoursynth/VapourSynth.h"|<VapourSynth.h>|g' \
- -e 's|"vapoursynth/VSHelper.h"|<VSHelper.h>|g' \
- -e 's|"fftw3.h"|<fftw3.h>|g' \
- -i FFTSpectrum.c
-
- echo "all:
- gcc -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o FFTSpectrum.o FFTSpectrum.c
- gcc -shared $(pkg-config --libs fftw3f) -fPIC ${LDFLAGS} -o lib${_plug}.so FFTSpectrum.o" > Makefile
+ mkdir -p build
}
build() {
- make -C "${_plug}"
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
}
package(){
- cd "${_plug}"
- install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ DESTDIR="${pkgdir}" ninja -C build install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}