summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-07-08 12:01:42 +0200
committerGustavo Alvarez2016-07-08 12:01:42 +0200
commit8ede5e6ad5f270041faad1666dbdaee356a6262c (patch)
tree188d480cca3f00b9baa0c7f4db676c1d301aff23
downloadaur-8ede5e6ad5f270041faad1666dbdaee356a6262c.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da28004b400c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jul 8 10:01:42 UTC 2016
+pkgbase = vapoursynth-plugin-finedehalo-git
+ pkgdesc = Plugin for Vapoursynth: finedehalo (GIT version)
+ pkgver = r1
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=173672
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-mvsfunc-git
+ depends = vapoursynth-plugin-havsfunc
+ provides = vapoursynth-plugin-finedehalo
+ conflicts = vapoursynth-plugin-finedehalo
+ conflicts = vapoursynth-plugin-resamplehq-git
+ source = finedehalo::git+https://gist.github.com/bcd427ec0fa8fdf7c45433917521bac4.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-finedehalo-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c7631a95451
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=finedehalo
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='http://forum.doom9.org/showthread.php?t=173672'
+license=('GPL')
+depends=('vapoursynth-plugin-mvsfunc-git'
+ 'vapoursynth-plugin-havsfunc'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}"
+ 'vapoursynth-plugin-resamplehq-git')
+source=("${_plug}::git+https://gist.github.com/bcd427ec0fa8fdf7c45433917521bac4.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}