summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:34:32 +0200
committersl1pkn072015-06-08 20:34:32 +0200
commit6972993f01bdf92b1954881e34c7740a4c8e692f (patch)
treec000da262d9157eaba175e8b0efd2188b7e4208a
downloadaur-6972993f01bdf92b1954881e34c7740a4c8e692f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..650f01940e45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vapoursynth-plugin-finesharp-git
+ pkgdesc = Plugin for Vapoursynth: finesharp (GIT Version)
+ pkgver = r5
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=166524
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = vapoursynth
+ provides = vapoursynth-plugin-finesharp
+ conflicts = vapoursynth-plugin-finesharp
+ source = finesharp::git+https://gist.github.com/8676fd350d4b5b223ab9.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-finesharp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..685f7da0a189
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=finesharp
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r5
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=166524"
+license=('GPL')
+depends=('vapoursynth')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+makedepend=('git')
+source=("${_plug}::git+https://gist.github.com/8676fd350d4b5b223ab9.git")
+sha1sums=('SKIP')
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}