summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:02:01 +0200
committerGustavo Alvarez2016-10-19 22:02:01 +0200
commit9eec084b107867ed6bb6aa912294c3e138caf722 (patch)
treea57bfabbf6a651b2b1b58dbe4bc1595d26fd7bc5
parentcdb4b7faecd7a28d8424eb033e4b1170eb33d5e8 (diff)
downloadaur-9eec084b107867ed6bb6aa912294c3e138caf722.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eb5d13a3bd6..45732f3d95c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Aug 21 15:53:16 UTC 2016
+# Wed Oct 19 20:01:48 UTC 2016
pkgbase = vapoursynth-plugin-finesharp-git
pkgdesc = Plugin for Vapoursynth: finesharp (GIT Version)
pkgver = r8
@@ -12,7 +12,7 @@ pkgbase = vapoursynth-plugin-finesharp-git
provides = vapoursynth-plugin-finesharp
conflicts = vapoursynth-plugin-finesharp
source = finesharp::git+https://gist.github.com/8676fd350d4b5b223ab9.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-finesharp-git
diff --git a/PKGBUILD b/PKGBUILD
index da22c0e9d1bc..9af45f29384d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,9 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
makedepend=('git')
source=("${_plug}::git+https://gist.github.com/8676fd350d4b5b223ab9.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -23,5 +23,7 @@ pkgver() {
}
package() {
- install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}