summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordummyx2021-08-08 00:41:18 +0900
committerdummyx2021-08-08 00:41:18 +0900
commit003e642985248f0621444539f0bf4743faaa525b (patch)
treeac1e9fe548004cf272db0075d835f70cccd071a9
parent9449f8c30ebc4b058dbae6aff364394481f192c5 (diff)
downloadaur-003e642985248f0621444539f0bf4743faaa525b.tar.gz
Mark only strictly needed packages as dependencies
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD50
2 files changed, 50 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e165cc3c51f0..285cb354eac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,37 @@
pkgbase = vapoursynth-plugin-havsfunc
pkgdesc = Plugin for Vapoursynth: havsfunc
pkgver = r33
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/HomeOfVapourSynthEvolution/havsfunc
arch = any
license = GPL
makedepends = git
depends = vapoursynth
depends = vapoursynth-plugin-adjust-git
- depends = vapoursynth-plugin-addgrain-git
- depends = vapoursynth-plugin-awarpsharp2-git
- depends = vapoursynth-plugin-bilateral-git
- depends = vapoursynth-plugin-ctmf-git
- depends = vapoursynth-plugin-dctfilter-git
- depends = vapoursynth-plugin-deblock
- depends = vapoursynth-plugin-dfttest-git
- depends = vapoursynth-plugin-eedi2-git
- depends = vapoursynth-plugin-eedi3cl-git
- depends = vapoursynth-plugin-fft3dfilter-git
- depends = vapoursynth-plugin-f3kdb
- depends = vapoursynth-plugin-fluxsmooth
- depends = vapoursynth-plugin-fmtconv
- depends = vapoursynth-plugin-knlmeanscl
- depends = vapoursynth-plugin-mvtools
- depends = vapoursynth-plugin-nnedi3_resample-git
- depends = vapoursynth-plugin-nnedi3-git
- depends = vapoursynth-plugin-nnedi3cl-git
- depends = vapoursynth-plugin-sangnom-hg
- depends = vapoursynth-plugin-svpflow1
- depends = vapoursynth-plugin-svpflow2-bin
- depends = vapoursynth-plugin-ttempsmooth-git
- depends = vapoursynth-plugin-znedi3-git
+ depends = vapoursynth-plugin-mvsfunc-git
+ optdepends = vapoursynth-plugin-addgrain-git
+ optdepends = vapoursynth-plugin-awarpsharp2-git
+ optdepends = vapoursynth-plugin-bilateral-git
+ optdepends = vapoursynth-plugin-ctmf-git
+ optdepends = vapoursynth-plugin-dctfilter-git
+ optdepends = vapoursynth-plugin-dfttest-git
+ optdepends = vapoursynth-plugin-eedi2-git
+ optdepends = vapoursynth-plugin-deblock
+ optdepends = vapoursynth-plugin-eedi3cl-git
+ optdepends = vapoursynth-plugin-fft3dfilter-git
+ optdepends = vapoursynth-plugin-f3kdb
+ optdepends = vapoursynth-plugin-fluxsmooth
+ optdepends = vapoursynth-plugin-fmtconv
+ optdepends = vapoursynth-plugin-knlmeanscl
+ optdepends = vapoursynth-plugin-mvtools
+ optdepends = vapoursynth-plugin-nnedi3_resample-git
+ optdepends = vapoursynth-plugin-nnedi3-git
+ optdepends = vapoursynth-plugin-nnedi3cl-git
+ optdepends = vapoursynth-plugin-sangnom-hg
+ optdepends = vapoursynth-plugin-svpflow1
+ optdepends = vapoursynth-plugin-svpflow2-bin
+ optdepends = vapoursynth-plugin-ttempsmooth-git
+ optdepends = vapoursynth-plugin-znedi3-git
provides = vapoursynth-plugin-havsfunc
conflicts = vapoursynth-plugin-havsfunc-git
source = havsfunc-r33.tar.gz::https://github.com/HomeOfVapourSynthEvolution/havsfunc/archive/r33.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 7095fe8bb3ac..1e32d725704c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,37 +4,37 @@
_plug=havsfunc
pkgname=vapoursynth-plugin-${_plug}
pkgver=r33
-pkgrel=1
+pkgrel=2
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('any')
url='https://github.com/HomeOfVapourSynthEvolution/havsfunc'
license=('GPL')
depends=('vapoursynth'
'vapoursynth-plugin-adjust-git'
- 'vapoursynth-plugin-addgrain-git'
- 'vapoursynth-plugin-awarpsharp2-git'
- 'vapoursynth-plugin-bilateral-git'
- 'vapoursynth-plugin-ctmf-git'
- 'vapoursynth-plugin-dctfilter-git'
- 'vapoursynth-plugin-deblock'
- 'vapoursynth-plugin-dfttest-git'
- 'vapoursynth-plugin-eedi2-git'
- 'vapoursynth-plugin-eedi3cl-git'
- 'vapoursynth-plugin-fft3dfilter-git'
- 'vapoursynth-plugin-f3kdb'
- 'vapoursynth-plugin-fluxsmooth'
- 'vapoursynth-plugin-fmtconv'
- 'vapoursynth-plugin-knlmeanscl'
- 'vapoursynth-plugin-mvtools'
- 'vapoursynth-plugin-nnedi3_resample-git'
- 'vapoursynth-plugin-nnedi3-git'
- 'vapoursynth-plugin-nnedi3cl-git'
- 'vapoursynth-plugin-sangnom-hg'
- 'vapoursynth-plugin-svpflow1'
- 'vapoursynth-plugin-svpflow2-bin'
- 'vapoursynth-plugin-ttempsmooth-git'
- 'vapoursynth-plugin-znedi3-git'
- )
+ 'vapoursynth-plugin-mvsfunc-git')
+optdepends=('vapoursynth-plugin-addgrain-git'
+ 'vapoursynth-plugin-awarpsharp2-git'
+ 'vapoursynth-plugin-bilateral-git'
+ 'vapoursynth-plugin-ctmf-git'
+ 'vapoursynth-plugin-dctfilter-git'
+ 'vapoursynth-plugin-dfttest-git'
+ 'vapoursynth-plugin-eedi2-git'
+ 'vapoursynth-plugin-deblock'
+ 'vapoursynth-plugin-eedi3cl-git'
+ 'vapoursynth-plugin-fft3dfilter-git'
+ 'vapoursynth-plugin-f3kdb'
+ 'vapoursynth-plugin-fluxsmooth'
+ 'vapoursynth-plugin-fmtconv'
+ 'vapoursynth-plugin-knlmeanscl'
+ 'vapoursynth-plugin-mvtools'
+ 'vapoursynth-plugin-nnedi3_resample-git'
+ 'vapoursynth-plugin-nnedi3-git'
+ 'vapoursynth-plugin-nnedi3cl-git'
+ 'vapoursynth-plugin-sangnom-hg'
+ 'vapoursynth-plugin-svpflow1'
+ 'vapoursynth-plugin-svpflow2-bin'
+ 'vapoursynth-plugin-ttempsmooth-git'
+ 'vapoursynth-plugin-znedi3-git')
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}-git")