summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:35:09 +0200
committersl1pkn072015-06-08 20:35:09 +0200
commitdc026ce2bbac25fd7e34eb72c11d020264b774dd (patch)
tree66f78bc8ad4fc1fcd02b7f9f19f539a453e2345d
downloadaur-dc026ce2bbac25fd7e34eb72c11d020264b774dd.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97e67989054c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vapoursynth-plugin-havsfunc
+ pkgdesc = Plugin for Vapoursynth: havsfunc
+ pkgver = r17
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=166582
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ source = https://dl.dropbox.com/u/6596386/vapoursynth-plugins/havsfunc-r17.7z
+ sha1sums = 490a7b067b2bbca84db624285cc24b6b3c91c713
+
+pkgname = vapoursynth-plugin-havsfunc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26a7391de8bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=havsfunc
+pkgname=vapoursynth-plugin-${_plug}
+pkgver=r17
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=166582"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+source=("https://dl.dropbox.com/u/6596386/vapoursynth-plugins/${_plug}-${pkgver}.7z")
+sha1sums=('490a7b067b2bbca84db624285cc24b6b3c91c713')
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+package() {
+ install -Dm644 "${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}
+